Skip to main content
Advanced Search
Search Terms
Content Type

Exact Matches
Tag Searches
Date Options
Updated after
Updated before
Created after
Created before

Search Results

12 total results found

Introduction

Superbase NG IDE Users Guide

This application is an Integrated Development Environment (IDE) to write, execute and debug Superbase NG applications. There is only one Superbase NG IDE release version, one that runs on Windows XP and later operating systems. The older releases also included...

Introduction

Superbase NG IDE Users Guide The Superbase NG Project

Source code files in SIMPOL are stored with one of two file extensions: sma or smu. The first extension indicates that the file content is stored in an ASCII format (1 byte per character) and the second one indicates that the file content is stored in Unicode ...

The Organization of Files in a Project

Superbase NG IDE Users Guide The Superbase NG Project

A SIMPOL project is stored on the hard disk as a group of files with the following extensions smj, sma, smu, smp, sml, and smz with an appropiate folder structure. I will explain the folder structure using the above project example. The basis of every project...

SIMPOL Server Pages

Superbase NG IDE Users Guide The Superbase NG Project

A SIMPOL server page is a file with the extension smz, the contents of which is HTML but which also includes blocks of SIMPOL source code. The blocks of source code are inside server page comment blocks (in between <% and %> tags), so if we launch the HTML vie...

Server Page Directives

Superbase NG IDE Users Guide The Superbase NG Project

This section covers the syntax of the server page and the specific directives provided Multiline Comments A multiline comment can consist of any piece of text between the start tag <%-- and the end tag --%>. The comment can cover multiple lines and since it ...

Starting the IDE

Superbase NG IDE Users Guide The Superbase NG IDE Environment

The IDE can be started from the command line or another program in various ways that will be outlined below: Command Line Parameters Description sbngide.exe None The application is launched. sbngide.exe filename First, the application is launche...

Editing Documents

Superbase NG IDE Users Guide The Superbase NG IDE Environment

Editing documents is the primary objective of the Superbase NG IDE. As in any editor, a user can create a document and store it in a file, open an existing file, update the content before saving it, etc. There are many features in the IDE that make it easy to ...

Control Bars

Superbase NG IDE Users Guide The Superbase NG IDE Environment

Control bars are a set of windows that share a common level of functionality. At the bottom of any control bar there is a tab control that allows easy selection of any window owned by the control bar. There are four different control bars in the Superbase NG I...

Menus

Superbase NG IDE Users Guide The Superbase NG IDE Environment

These menus are located at the top of the application. Any menu when selected displays an options list. Each option performs a specific task. File Menu Table 4.8. File Menu Items Menu Item Description New Creates a new document. A list with the...

Tool Bars

Superbase NG IDE Users Guide The Superbase NG IDE Environment

There are three toolbars available in the application. Almost all of the buttons have an associated entry in the menus, so for help regarding the use of a button, please refer to the help for the associated menu command. Standard Toolbar This is the standard...

Important Dialogs

Superbase NG IDE Users Guide The Superbase NG IDE Environment

The following is a description of the main application dialog boxes. Breakpoint Manager This dialog box manages the active project breakpoints status. A breakpoint is a mark added to aid debugging. When the application reaches that line, it will interrupt th...

Keyboard Shortcuts

Superbase NG IDE Users Guide The Superbase NG IDE Environment

Below is a list of the keyboard shortcuts available in the IDE. This list can also be viewed by choosing "Keyboard Map..." from the help menu. Edit Shortcut Keys Keys Description Ctrl+Shift+8 Toggle view whitespace Ctrl+A Select all Ctrl+C Cop...